PR

 Mozillaの主力ブラウザであるFirefox 3について,ユーザーを悪意のあるハッカーの攻撃にさらす,少なくとも7件の明文化されたセキュリティ上の脆弱性を修正する新たなバージョンが公開された。

 Firefox 3.0.6では,任意のコードを実行される攻撃につながる可能性のある,重要度が「最高」のセキュリティホール1件と,データ盗難に使われる可能性のある,重要度が「高」のバグ2件を修正している。

 詳細は以下の通りだ。

  • MFSA 2009-06: Web ページをキャッシュさせないことを目的とした特定の HTTP ディレクティブが Firefox 3 で無視されてしまうことが,Paul Nel 氏によって報告されました。該当するディレクティブは,HTTPS ページで用いられる Cache-Control: no-store と Cache-Control: no-cache です。共有のシステムでは,これらの HTTP ディレクティブに依存したアプリケーションが個人情報を曝してしまう潜在的な可能性がありました。システム上の他のユーザがこの脆弱性を利用すると,ブラウザの戻るボタンでページを遷移することで,不適切にキャッシュされた個人情報が含まれるページを表示することが可能でした。
  • MFSA 2009-05:HTTPOnly 属性の指定された Cookie が,XMLHttpRequest.getResponseHeader と XMLHttpRequest.getAllResponseHeaders API を通じて JavaScript によって読み取り可能であることが,開発者で Mozilla コミュニティメンバーの Wladimir Palant 氏によって報告されました。この脆弱性は,document.cookie への JavaScript アクセスを制限することを意図した,HTTPOnly フラグによって提供されるセキュリティ機構を回避するものでした。
  • MFSA 2009-04: (重要度:中)以前 Liu Die Yu 氏によって報告された,ローカルインターネットショートカットファイルを用いて他のサイトにアクセスできてしまう脆弱性 (MFSA 2008-47) の修正が,about:plugins など特権を持つ about: URL へのリダイレクトによって回避できてしまうことが,Mozilla セキュリティ研究者の Georgi Guninski 氏によって報告されました。悪質な HTML ファイルと .desktop ショートカットファイルという 2 つのファイルを,攻撃者が被害者にダウンロードさせることができた場合,そのショートカットを通じて HTML ドキュメントからクローム特権を持つドキュメントを読み込ませ,両方のドキュメントを生成元が同一であるかのようにブラウザに扱わせることが可能でした。この脆弱性は,攻撃者によって,クロームドキュメントに任意のコードを注入し,それをクローム特権で実行するのに利用される,潜在的な可能性をはらむものでした。この攻撃は複雑さの度合いが比較的高いことから,問題の重要度は「中」と判断されました。
  • MFSA 2009-03:(重要度:高)フォーム入力コントロールの種類を閉じたタブの復元時に変更できてしまうことが,Mozilla セキュリティ研究者の moz_bug_r_a4 氏によって報告されました。攻撃者は,入力コントロールのテキスト値を,攻撃者にとって既知の場所にあるローカルファイルのパスに書き換えることが可能でした。さらに,その後タブが閉じられ,被害者がそれを開き直すよう誘導された場合,攻撃者はこの脆弱性を利用して,そのタブの復元時に入力コントロールの種類を file に変更することが可能でした。その際,ページ内のスクリプトでフォームを自動的に送信することで,ユーザのローカルファイルの中身を読み取ることができてしまいました。
  • MFSA 2009-02:(重要度:高)クローム XBL メソッドを window.eval と組み合わせることで,同一生成元ポリシーに反して,他の Web サイトのコンテキストで任意の JavaScript を実行できてしまうことが,Mozilla セキュリティ研究者の moz_bug_r_a4 氏によって報告されました。Firefox 2 はこの問題の影響を受けません。修正版にアップグレードするまで JavaScript を無効にしてください。
  • MFSA 2009-01:(重要度:最高)Firefox やその他の Mozilla ベースの製品で利用されているブラウザエンジンに含まれていた安定性に関するいくつかのバグを,Mozilla 開発者が特定,修正しました。これらクラッシュの一部は,特定状況下でメモリ破壊の形跡が見られ,条件が整えば任意のコード実行に利用可能と思われるものでした。

 このパッチは,Firefoxに組み込まれているアップデートの仕組みで自動的に提供される。すべてのFirefoxをインストールしているユーザーは,ブラウザを使っているかどうかに関わらず,今回のパッチを優先度の高いアップデートとして取り扱うべきだ。

この記事は海外CNET Networks発のニュースをシーネットネットワークスジャパン編集部が日本向けに編集したものです。海外CNET Networksの記事へ

関連記事