PR
最新版「Lhaplus 1.55」の設定画面例
最新版「Lhaplus 1.55」の設定画面例
[画像のクリックで拡大表示]

 情報処理推進機構(IPA)などは2007年9月21日、ファイル圧縮・解凍ソフト「Lhaplus(ラプラス)」に脆弱性(セキュリティホール)が見つかったことを明らかにした。細工が施されたファイルを読み込むだけで、悪質なプログラム(ウイルスなど)を実行される危険性がある。対策は、最新版へのバージョンアップ。

 Lhaplusは、20種類以上のファイル形式を扱える圧縮・解凍ソフト。フリーソフトで、国内で広く使われている。今回、Lhaplusが扱えるファイル形式の一種「ARJ形式」の処理に脆弱性が見つかった。細工が施されたARJ形式圧縮ファイルを読み込むと「バッファオーバーフロー」と呼ばれるエラーが発生し、ファイルに仕込まれた悪質なプログラムを勝手に実行される恐れがある。

 影響を受けるのは、Lhaplusのバージョン1.54以前(1.54を含む)。対策は、同日公開された最新版「Lhaplus 1.55」へバージョンアップすること。Lhaplus 1.55のインストーラーや、バージョン1.5x(1.50以降)を1.55へバージョンアップするアップデータは、Lhaplus作者のWebサイトからダウンロードできる。