PR

 こんにちは、兼宗です。最近は人との出会いを通して刺激をもらうことが多くなりました。このコラムでは、みなさんにもその一端を紹介できれば嬉しいです。

 今回は私が作っているプログラミング言語と、3月に行われた教育用言語のワークショップについてご紹介します。

 前回、プログラムはプログラミング言語という「人間が書けて機械に理解できる」言葉で書くことをお話しました。実際の例として、今日は私が2000年に作った「ドリトル」という名前の言語を紹介します。

 ドリトルは初心者の学習用に設計した言語で、小学校から企業までのいろいろな教育現場で使われています。たとえば次のプログラム例のように、日本語を使って数行でプログラムを書けるのが特徴です。ドリトルのWebサイトからダウンロードできますので、興味のある人は使ってみてください(*1)。ドリトルのプログラムは次回に詳しく解説します。

ドリトルのプログラム例

カメ太=タートル!作る。
三角=「カメ太!100 歩く 120 右回り」!3回 繰り返す 図形にする (赤)塗る。
タイマー!作る「三角!30 左回り」実行。

ドリトルプログラム実行例【ドリトルのプログラム実行例】左のアニメはGIFアニメーションで作成したので、三角がくるくると回り続けていますが、実際は3回転して止まります(編集部)

 さて、3/29に東京で「教育用プログラミング言語に関するワークショップ2006」が開かれました。これはドリトルをはじめとする、さまざまな教育用言語の関係者が一堂に会する日本で初めての試みです。会場には100名を超す参加者が集まり、1週間前には申込を締め切らなければならないほどの盛況ぶりでした。主催者と発表者の方々をはじめ、参加してくださったみなさまに感謝します。

 今回のワークショップは第1回ということもあり、さまざまな言語の紹介が行われました。午前は実績のある言語として、多くの実用ソフトの開発に使われている「Java」「JavaScript」「C++」の大学等での授業の紹介と、長く情報教育に使われてきた「Basic」「Logo」「Lisp」の紹介がありました。

 午後は最近教育用に開発された言語として、海外製の「Squeak」とその日本語実装である「言霊」、事務処理にもつかえる「ひまわり/なでしこ」、今回紹介した「ドリトル」、ゲーム作成に便利な「Tonyu」「HSP」、大学入試でも使われている「PEN」、美術教育用の「Rosetta」、プログラム不要のプログラミング言語(?)「ビスケット」が紹介されました。

 最後にパネルディスカッションが行われ、いくつかの言語の発表者とともに、この日のために韓国から駆けつけてくれた高麗大学の李元揆教授を交えて意見交換をしました。李教授は韓国の情報教育の改革について説明し、学校教育の中で積極的にプログラミングを取り入れていくことの重要性を強調しました。

 ワークショップのページでは、今回紹介された各言語について、それぞれの特徴とサイトのURLを紹介しています。興味のある方はご覧ください。いくつかの言語については、今回の連載の中で紹介していきたいと考えています。また、日本の学校での情報教育についても説明します。

 では、次回はドリトルのプログラムをみなさんと作ってみることにします。どうぞお楽しみに。