PR

 今回は、はじめてのプログラミングとして、ドリトルという言語を使ってみましょう。最初に、インターネットからドリトルを入手します。

 ドリトルを入手しましょう。「プログラミング言語ドリトル」のページにアクセスすると、図1の画面が開きます。


【図1: ドリトルのトップページ】

 「ダウンロード」をクリックすると、図2のダウンロードページに移動します。


【図2: ドリトルのダウンロードページ】

 「dl126nojava.zip」をデスクトップにダウンロードして解凍してください。
 解凍されたフォルダの中にある、「dolittle.js」というファイルをクリック
すると、図3のようにドリトルが起動します。


【図3: ドリトルの起動画面】

 マニュアルは、図1のドリトルのサイト(*)から「ドリトル入門」と「命令一覧」
のページをご覧ください。

 では、さっそくプログラムを書いてみましょう。ドリトルのプログラムを編集
するときは、画面上部のタブで「編集画面」に切り替えます。最初のプログラ
ムは、たった1行です。編集画面で、図4のように入力してください。

タートル!作る。


【図4: ドリトルの編集画面】

 プログラムを入力したら、画面下の「実行!」ボタンで実行します。すると、
 画面が実行画面に切り替わり、図5のように画面にカメが現れます。

0605-3-5.jpg
【図5: カメが現れた】

 このプログラムでは、タートルオブジェクト(カメのオブジェクト)に、自分の
複製を作るように命令を送りました。「カメの神様、あなたの分身を1匹作っ
てください」という雰囲気です。その結果、画面に1匹のカメが作られました。
 めでたし、めでたし。

 さて、画面のカメに命令を送り、動かしてみたいと思います。しかし、現在は
名前がないので呼びかけることができません。そこで、先ほどのプログラムを
修正して、オブジェクトに名前を付けてみましょう。

カメ太=タートル!作る。

 ここでは「カメ太」という名前にしてみました。この名前はドリトルのプログ
ラムではよく使われます。日本語変換でうまく変換できないときは、ひらがな
で「かめた」と書いても構いません。

 では、先ほどのプログラムの次の行に、もう1行プログラムを追加しましょう。
オブジェクトには、名前で呼びかける形で命令を送ることができます。ちょう
ど、「カメ太君、100歩あるいて」という雰囲気です。

カメ太!100 歩く。

 命令は続けて送ることもできます。2行目は次のように長くしてみましょう。
 「カメ太君、100歩あるいて90度左に回って100歩あるいて」という雰囲気です。

カメ太!100 歩く 90 左回り 100 歩く。

 編集画面で図6のように入力したプログラムを実行すると、実行画面には図7の
ように線が描かれます。

0605-3-6.jpg
【図6: 編集画面のプログラム】

0605-3-7.jpg
【図7: 線が描かれた】

 次回は、カメを操作するボタンを作ってみたいと思います。

【PCオンライン編集部からのお願い】

 ドリトルの利用に当たっては個々のユーザー自身の責任において行ってください。
 コラムで紹介するドリトルのプログラム動作については編集部でも確認していま
すが、すべてのユーザーのパソコン環境で同じように動作することを保証するもの
ではありません。申し訳ありませんが、紹介する内容について、個別のご質問には
お答えしかねますのでご了承ください。
 より詳しい情報は http://dolittle.eplang.jp/ をご参照ください。
 よろしくお願いいたします。