PR

前回はドリトルというプログラミング言語をパソコンにインストールし、それ
を使って簡単なプログラムを作ってみました。今回は、ゲームプログラムを作
ります。1行ずつ書いて、動きを確かめながら進めていきましょう。

最初に、主人公のカメを作ります。名前は「カメ太」にしました。もちろん、
「かめた」など好きな名前を使ってください。編集画面に次の1行を書いて
「実行」ボタンで実行すると、画面にカメが現れます。

   カメ太=タートル!作る。


【図1:カメが作られた】

次にカメを操作するボタンを作ります。何をするボタンかわかるように、ここ
では「前」という文字を書くことにします。プログラムに次の1行を加えて実
行すると、画面にボタンが作られます。

   前進ボタン=ボタン!”前”作る。


【図2:ボタンが作られた】

ボタンはできましたが、押してみると...何も起きません。ボタンはまだ、
「押されたときに何をすればよいか」を知らないのです。そこで、押されたと
きの動作を定義してみましょう。ここでは、ボタンを押すたびにカメ太が10歩
ずつ歩くようにしてみます。

   前進ボタン:動作=「カメ太!10 歩く」。


【図3:押すと動いた!】

ここまでのプログラムは次の3行です。「カメ太」と「前進ボタン」という2つ
のオブジェクトを作り、前進ボタンには押されたときの動作を定義しました。
「動作」のように、オブジェクトにはメソッドと呼ばれる新しい命令を定義す
ることができます。

   カメ太=タートル!作る。
   前進ボタン=ボタン!”前”作る。
   前進ボタン:動作=「カメ太!10 歩く」。

まっすぐ歩くだけではつまらないので、もうひとつボタンを作って曲がれるよ
うにしてみましょう。次の1行を加えて実行してみると...

なぜかもうひとつのボタンが現れません。

   右ボタン=ボタン!”右”作る。


【図4:あれれ、ボタンができない】

実はボタンは作られているのですが、2個のボタンがぴったり同じ場所に重なっているために1個しか見えないのでした。

そこで、新しいボタンを右に120歩分ずらしてみます。「x y 移動する」は、右にx歩、上にy歩動く命令です。

   右ボタン=ボタン!”右”作る 120 0 移動する。


【図5:2つのボタンが表示された】

この右ボタンには30度回るという動作を定義しておきましょう。

   右ボタン:動作=「カメ太!30 右回り」。


【図6:カメ太の向きが変わった】

これで、ボタンを使ってカメ太を動かせるようになりました。前進と右回転し
かできませんが、これだけでも結構楽しいです。動かして動作を確かめてみて
ください。


【図7:カメでお絵かき】

ここまでのプログラムは次の5行です。「前進ボタン」と「右ボタン」には、
押されたときに実行する命令が、それぞれ「動作」メソッドとして定義されて
います。

   カメ太=タートル!作る。
   前進ボタン=ボタン!”前”作る。
   前進ボタン:動作=「カメ太!10 歩く」。
   右ボタン=ボタン!”右”作る 120 0 移動する。
   右ボタン:動作=「カメ太!30 右回り」。

次回(6月14日掲載予定)はいよいよドリトル入門最終回。
たった11行のプログラムでゲームを作ってみます。お楽しみに。

【PCオンライン編集部からのお願い】
 ドリトルは個々のユーザー自身の責任においてご利用ください。
 コラムで紹介するドリトルのプログラム動作については編集部でも確認していま
すが、すべてのユーザーのパソコン環境で同じように動作することを保証するもの
ではありません。申し訳ありませんが、紹介する内容について、個別のご質問には
お答えしかねますのでご了承ください。
 より詳しい情報は http://dolittle.eplang.jp/ をご参照ください。
 よろしくお願いいたします。